Обновление Angular 12 — для компилятора Angular требуется TypeScript

Я обновил свой проект до последней версии angular. После обновления с помощью ng update я получаю сообщение, что все обновлено. (Последний шаг в моем процессе. Необходимые пакеты уже обновлены)

Хорошо, но когда я обслуживаю проект, я получаю следующую ошибку:

Error: The Angular Compiler requires TypeScript >=4.2.3 and <4.3.0 but 4.3.2 was found instead. 

Я уже пробовал: npm install [email protected], но такой версии не существует. Я предпочитаю не переходить на более раннюю версию. Я стараюсь поддерживать свои проекты в актуальном состоянии.

Как я могу это исправить.

Обратите внимание, что там написано <4.3.0, поэтому 4.3.0 в любом случае будет недействительным. Вам необходимо установить 4.2.4. Я предпочитаю не переходить на более раннюю версию — если вашим зависимостям требуется другая версия, это не ваш выбор.   —  person Babulaas    schedule 07.06.2021

Убедитесь, что вы ссылаетесь на https://update.angular.io/ во время обновлений. Это большая полезность   —  person Babulaas    schedule 07.06.2021

См. также:  Кипарисовые тесты периодически терпят неудачу
Понравилась статья? Поделиться с друзьями:
IT Шеф
Комментарии: 2
  1. Babulaas

    Как уже сказано в комментариях, Angular пока поддерживает только машинописный текст 4.2. Новейшую поддерживаемую версию можно установить с

    npm i [email protected]*
    

    Если вы действительно хотите использовать новейший машинописный текст, в вашем tsconfig можно установить флаг disableTypeScriptVersionCheck (хотя это не рекомендуется): https://angular.io/guide/angular-compiler-options#disabletypescriptversioncheck

  2. Babulaas

    Angular 12 поддерживает только Typescript 4.2. Вы должны изменить свой package.json вот так.

        "typescript": "~4.2.3"
    

    И перезапустите npm install.

Добавить комментарий

;-) :| :x :twisted: :smile: :shock: :sad: :roll: :razz: :oops: :o :mrgreen: :lol: :idea: :grin: :evil: :cry: :cool: :arrow: :???: :?: :!: