Пакет SDK для VSCode .NET Core не может быть найден

Я использую Ubuntu 20.04 (64-разрядный, настольный) и только что установил VS Code и .NET Core SDK.

Intellisense не работает, и я получаю сообщение об ошибке:

Не удается найти пакет SDK для .NET Core. Отладка .NET Core не будет включена. Убедитесь, что пакет SDK для .NET Core установлен и находится в пути.

Я переустановил .NET Core SDK (из SnapStore) и убедился, что VS Code не открыт при его установке.

После этого я мог использовать intellisense около 5 секунд, затем снова появилась ошибка, и intellisense перестал работать.

РЕДАКТИРОВАТЬ: при использовании сценария intall, как упоминал Бен, я получаю следующий результат:

dotnet-install: обратите внимание, что предполагаемое использование этого сценария предназначено для сценариев непрерывной интеграции (CI), где: dotnet-install: — SDK необходимо установить без взаимодействия с пользователем и без прав администратора. dotnet-install: — Установка SDK не должна сохраняться при нескольких запусках CI. dotnet-install: для настройки среды разработки или запуска приложений используйте установщики, а не этот сценарий. Посетите https://dotnet.microsoft.com/download, чтобы получить установщик.

dotnet-install: .NET Core SDK версии 3.1.409 уже установлен. dotnet-install: Добавление к текущему процессу ПУТЬ: /home/MYUSERNAME/.dotnet. Примечание. Это изменение будет видно только при поиске скрипта. dotnet-install: обратите внимание, что сценарий не разрешает зависимости во время установки. dotnet-install: чтобы проверить список зависимостей, перейдите на https://docs.microsoft.com/dotnet/core/install, выберите свою операционную систему и проверьте раздел «Зависимости». dotnet-install: установка успешно завершена.

См. также:  Различия между статическими и динамическими библиотеками
Понравилась статья? Поделиться с друзьями:
IT Шеф
Комментарии: 2
  1. AlpakaJoe

    Я бы не стал использовать .NET SDK от snap, поскольку приложения snap работают в контейнерной среде, что затрудняет их поиск другими приложениями. Пробовали ли вы установку с помощью руководства Microsoft? Я бы рекомендовал использовать установку по сценарию < / а>

    Я удалил Snap SDK и попытался использовать установку по сценарию, но это выдает ошибку, которую я добавил в свой исходный пост. person AlpakaJoe; 18.05.2021

  2. AlpakaJoe

    У меня была та же проблема, что и у меня

    1. удалить все службы, принадлежащие Visual Studio (не Vs Code)
    2. удалить VS Code и папку AppData \ Local \ Programs \ Microsoft VS Code
    3. загрузите новый пакет SDK ядра dotnet и установите vs code.

    Вы видели, что я использую Ubuntu? Потому что вы упомянули папку AppData, то есть только для Windows. person AlpakaJoe; 17.05.2021

    Также у меня нет Visual Studio, только VSCode, потому что нет Visual Studio для Linux. person AlpakaJoe; 17.05.2021

Добавить комментарий

;-) :| :x :twisted: :smile: :shock: :sad: :roll: :razz: :oops: :o :mrgreen: :lol: :idea: :grin: :evil: :cry: :cool: :arrow: :???: :?: :!: