ImportError: нет модуля с именем ‘typing’ при попытке установить пакет

Я хочу установить pygame на свой компьютер, когда я набираю pip в cmd, я получаю эту ошибку:

  File "C:\Python34\Scripts\pip3-script.py", line 9, in <module>
    load_entry_point('pip==21.1', 'console_scripts', 'pip3')()
  File "C:\Python34\lib\site-packages\setuptools-18.1-py3.4.egg\pkg_resources\__
init__.py", line 558, in load_entry_point
  File "C:\Python34\lib\site-packages\setuptools-18.1-py3.4.egg\pkg_resources\__
init__.py", line 2682, in load_entry_point
  File "C:\Python34\lib\site-packages\setuptools-18.1-py3.4.egg\pkg_resources\__
init__.py", line 2355, in load
  File "C:\Python34\lib\site-packages\setuptools-18.1-py3.4.egg\pkg_resources\__
init__.py", line 2361, in resolve
  File "C:\Users\user\AppData\Roaming\Python\Python34\site-packages\pip\__init__
.py", line 1, in <module>
    from typing import List, Optional
ImportError: No module named 'typing'

Python 3.4 не имеет модуля typing, обновите свой python до другой версии, предпочтительно Python 3.5 или выше.   —  person Belal Ahmed    schedule 01.05.2021

Отвечает ли это на ваш вопрос? Командная строка Pip ImportError: без именованного ввода модуля   —  person Belal Ahmed    schedule 01.05.2021

У меня есть Python 3.5.0a1, но он выдает ту же ошибку   —  person Belal Ahmed    schedule 01.05.2021

@python_user не помогло   —  person Belal Ahmed    schedule 01.05.2021

typing из 3.5.0 beta 1 не альфа-версии, которую вы используете, почему вы все равно используете альфа-версию сейчас? когда я имел в виду 3.5 или выше, я имел в виду финальную версию   —  person Belal Ahmed    schedule 01.05.2021

В pygame документации pygame.org/wiki/GettingStarted#Pygame%20Installation говорится: используйте Python 3.7.7 или новее. Предлагаю вам последовать этому совету. Python 3.4 датируется 2014 годом. Python 3.5 датируется 2015 годом. Оба достигли конца жизненного цикла. Нет веских причин для использования любого из них в новом коде, а также неразумно ожидать, что модули из PyPI будут поддерживать версии с истекшим сроком эксплуатации.   —  person Belal Ahmed    schedule 01.05.2021

@BoarGules Я не могу установить какой-либо пакет, дело не в том, что он выдает ошибку только при установке pygame   —  person Belal Ahmed    schedule 01.05.2021

См. также:  ошибка R10 при развертывании приложения Flask с докером на heroku
Понравилась статья? Поделиться с друзьями:
IT Шеф
Комментарии: 3
  1. Belal Ahmed

    Сделайте pip install typing, затем повторите попытку.

    Как мне установить что-то, если мой пип не только работает:, (я имею в виду, что я получу ту же ошибку person Belal Ahmed; 01.05.2021

    @BelalAhmed Неверно говорить, что ваш pip не работает. Он работает и довольно четко сообщает вам, что пакет, который вы пытаетесь установить, требует более поздней версии Python. Вы не можете исправить это, установив typing, потому что это стандартный библиотечный модуль, поэтому его установка не требуется и не возможна, если у вас есть правильная версия Python. Единственный способ установить его с pip — это если кто-то перенесет его на Python 3.4. Они этого не сделали, поэтому pip не будет его устанавливать. person Belal Ahmed; 01.05.2021

    @BoarGules эта проблема не связана с тем, что я пытаюсь установить, эта проблема, возможно, потому, что я установил последнюю версию pip, т.е. 21.1, и у меня нет необходимых инструментов сборки, но все же она создается или, другими словами, мне нужно установить более поздняя версия python (я думаю), кстати, спасибо, что приложили здесь немного усилий .. person Belal Ahmed; 01.05.2021

    Мой комментарий касался ответа, в котором говорилось, что вам следует установить typing. Я объяснял, почему это не сработает и почему это не имеет ничего общего с версией pip. person Belal Ahmed; 01.05.2021

    Это не дает ответа на вопрос. Чтобы критиковать или запрашивать разъяснения у автора, оставьте комментарий под его сообщением. — Из отзыва person Belal Ahmed; 02.05.2021

    @BoarGules Извините за недоразумение person Belal Ahmed; 02.05.2021

  2. Belal Ahmed

    сам pip не работает, поскольку он пытается импортировать набор текста, а набор текста не установлен. поэтому вы не можете запустить pip install, чтобы исправить это.

    TL; DR; 1. используйте dpkg или yum для установки набора текста (НО это может не решить проблему со сломанным pip.

    TL; DR; 2. Я думаю, что проблема связана с версией python2.7 / python3.x, возможно, просто используйте python3.

    Похожая проблема (с такой же ошибкой при неудачном импорте модуля ввода) возникла у меня на centos 7.9 после обновления pip. Решено для меня через некоторое время, просто перейдя на использование python3.

    Пип предложил это:

    You are using pip version 8.1.2, however version 21.1.1 is available.
    You should consider upgrading via the 'pip install --upgrade pip' command.
    

    Я несколько глупо переделал эту команду.

    Остерегайтесь, не всегда обновляйте вещи, как это предлагается!

    После этого pip upgrade pip был сломан:

    $ pip install httpserver
    Traceback (most recent call last):
      File "/bin/pip2", line 7, in <module>
        from pip._internal.cli.main import main
      File "/usr/lib/python2.7/site-packages/pip/__init__.py", line 1, in <module>
        from typing import List, Optional
    ImportError: No module named typing
    

    Итак, мы можем попробовать установить модули python в противном случае, например. через менеджер пакетов.

    yum install python-typing
    

    Это устанавливается нормально, однако при запуске pip появляется другая ошибка.

    pip install httpserver
    Traceback (most recent call last):
      File "/bin/pip", line 7, in <module>
        from pip._internal.cli.main import main
      File "/usr/lib/python2.7/site-packages/pip/_internal/cli/main.py", line 58
        sys.stderr.write(f"ERROR: {exc}")
                                       ^
    SyntaxError: invalid syntax
    

    Итак, настоящая проблема может заключаться в том, что некоторые пакеты python обновлены до python3.? синтаксис и pip работает на python2, какое-то несоответствие версии.

    Итак … ну, решение будет другим.

    В моем случае я обнаружил, что http.server — это объект только для python3. python2.7 был единственным питоном, установленным на этом компьютере. Скрипт, который я хотел запустить, требует python3.

    Таким образом, решение проблемы — просто использовать python3:

    # check python/pip related packages yum installed:
    rpm -qa |grep -E "python|pip"
    # install python 3
    yum install python3
    # now pip3 works, install some libs
    pip3 install chevron uuid requests
    

    Python 3 теперь установлен и работает, а pip3 для python 3 работает.

    После этого простой старый пип для python2.7 все еще не работает.

    Предлагаемое решение, оставленное в качестве упражнения для кого-то другого / будущего: Возможно, мы могли бы исправить, полностью удалив pip и снова установив старую версию. Пожалуйста, отредактируйте / обновите ответ или добавьте свой, если вы узнаете, как исправить плохой пип.

    Вы так правы! Ранее написание «pip» не давало никаких ошибок, но эта досадная ошибка началась после ее обновления! И да, ваш ответ правильный, теперь он работает нормально после переустановки! Спасибо!! наконец-то получил ответ на свой последний вопрос, так как меня все равно забанили, еще раз спасибо person Belal Ahmed; 19.05.2021

  3. Belal Ahmed

    Если вы случайно обновили свой pip, вы, к сожалению, не сможете использовать pip для восстановления предыдущей версии, так как pip сломан.

    Если вы были на Linux, таком как Centos, возможно, вы сможете переустановить pip, используя это:

    yum reinstall -y python2-pip.noarch python27-python-pip.noarch
    

    Но поскольку вы используете Windows, возможно, попробуйте переустановить pip, используя https://bootstrap.pypa.io/get-pip.py и укажите желаемую версию pip:

    https://bootstrap.pypa.io/get-pip.py
    
Добавить комментарий

;-) :| :x :twisted: :smile: :shock: :sad: :roll: :razz: :oops: :o :mrgreen: :lol: :idea: :grin: :evil: :cry: :cool: :arrow: :???: :?: :!: