Вопросы

Сбой задания Jenkins из-за старого рабочего пространства TFS

У меня есть работа Дженкинса, которая не работает из-за ошибки:

Произошла ошибка: путь XXXX уже сопоставлен в рабочей области YYYY; ZZZ \ ServiceAccount.

Учетная запись службы, на которую ссылаются, относится к домену, из которого недавно был перенесен сервер TFS.

Я пробовал различные исправления, чтобы удалить это отображение рабочего пространства:

  1. Запустите tfs workspace -delete {workspace name}; ZZZ \ ServiceAccount -noprompt -server: tfs server -login: YYY Это не сработает с сообщением об ошибке ZZZ \ ServiceAccount не является действительной учетной записью. Это правда, что учетная запись не существует в новом домене.

  2. Запустите tf workspaces / remove: *, чтобы удалить все кеши рабочей области. На этом закончено.

  3. Удалил содержимое% AppData% \ Local \ Microsoft \ Team Foundation \ 4.0 \ Cache.

Наш сервер TFS работает под управлением версии 2013.

  1. Пытался использовать Team Foundation Sidekicks 2013. Но это также не может найти никаких рабочих пространств для ZZZ \ ServiceAccount.
Читать:
TFS 2015 Rest Api - параметры запроса игнорируются и не фильтруют сборки?

Я пробовал как подчиненное устройство, на котором выполняется задание Jenkins, так и мастер Jenkins.

Где можно кэшировать это сопоставление рабочей области и как его удалить теперь, когда домен и пользователь больше не существуют?

Заранее спасибо.

Похожие записи

RuntimeError: цикл событий закрывается при попытке выполнить запрос https с помощью aiohttp

admin

Разница между 2D-массивом символов и char** (ИЛИ, 3D-массивом символов и char*** и т. д.)

admin

Невозможно развернуть Go в Oracle Cloud Function с помощью Cloud Shell

admin

ошибка R10 при развертывании приложения Flask с докером на heroku

admin

gitlab разрешение папки git-data

admin

Как работать с семантическим управлением версиями в Jenkins

admin