Expo React Native: ожидаемый диапазон версий: ~ 6.0.0 — установленная фактическая версия: ^ 5.0.1

После обновления Expo SDK 33 до 34 я начал замечать ошибку о том, что несколько пакетов expo npm должны быть как минимум v6.0.0 …

$ expo start -c
Starting project at /Users/nyxynyx/expoapp
Expo DevTools is running at https://localhost:19002

Some of your project's dependencies are not compatible with currently installed expo package version:
 - expo-ads-admob - expected version range: ~6.0.0 - actual version installed: ^5.0.1
 - expo-analytics-amplitude - expected version range: ~6.0.0 - actual version installed: ^5.0.1
 - expo-barcode-scanner - expected version range: ~6.0.0 - actual version installed: ^5.0.1
 - expo-permissions - expected version range: ~6.0.0 - actual version installed: ^5.0.1
Your project may not work correctly until you install the correct versions of the packages.
To install the correct versions of these packages, please run: expo install [package-name ...]

...

Пошел вперед, чтобы обновить эти пакеты

$ npm install --save expo-ads-admob expo-analytics-amplitude expo-barcode-scanner expo-permissions
npm WARN The package react-native-dotenv is included as both a dev and production dependency.

+ [email protected]
+ [email protected]
+ [email protected]
+ [email protected]
updated 4 packages and audited 38421 packages in 5.052s
found 11 low severity vulnerabilities
  run `npm audit fix` to fix them, or `npm audit` for details

Также пробовал очистить кеши, используя:

rm -rf node_modules
npm cache clean
npm install
watchman watch-del-all 
rm -fr $TMPDIR/metro*
expo start -c

Однако существует такое же предупреждающее сообщение о необходимости v6.0.0 +. Приложение работает нормально (сканер штрих-кода и т. Д.) В клиенте Expo iOS. Что нам делать?

См. также:  Python: как импортировать пользовательский модуль
Понравилась статья? Поделиться с друзьями:
IT Шеф
Комментарии: 1
  1. Nyxynyx

    Если вы используете Expo, я не думаю, что это правильный способ его установки. Если вы хотите установить собственный модуль из Expo, используйте эту команду.

    Пример

    expo install expo-ads-admob
    

    Использование expo install вместо npm install --save успешно установило версию v6.0.0 этих пакетов expo! person Nyxynyx; 30.07.2019

    package.json также был автоматически обновлен, чтобы отразить "^6.0.0" требования к версии. Если node_modules будет удален и переустановлен, можно ли просто запустить npm install? Или нам нужно использовать expo install <packagename> для отдельной установки пакетов expo? person Nyxynyx; 30.07.2019

    Пакет на случай удаления и установки node_modules. Следует использовать npm install или yarn install, потому что версия отражена в Package.json и необходимо установить другие модули. person Nyxynyx; 30.07.2019

Добавить комментарий

;-) :| :x :twisted: :smile: :shock: :sad: :roll: :razz: :oops: :o :mrgreen: :lol: :idea: :grin: :evil: :cry: :cool: :arrow: :???: :?: :!: