ОШИБКА в несовпадении версии метаданных для модуля для модуля узла angular2-multiselect-dropdown

После обновления модуля узла angular2-multiselect-dropdown с версии 3.2.1 до версии 4.0.0. Затем, при запуске команды angular built, она выдает «ОШИБКА в несовпадении версии метаданных для модуля». Для информации: Я использую yarn PM. Пожалуйста, помогите мне в этом.

Я использую angular (v4), @ angular / cli: 1.2.7, node-v8.2.1

ОШИБКА в несовпадении версии метаданных для модуля /Users/welcome/wed/project/gui/management/node_modules/angular2-multiselect-dropdown/angular2-multiselect-dropdown.d.ts, обнаружена версия 4, ожидается 3

ОШИБКА в ./src/main.ts Модуль не найден: Ошибка: не удается разрешить ‘./$$_gendir/app/app.module.ngfactory’ в ‘/ Users / welcome / wed / project / gui / management / src ‘@ ./src/main.ts 3: 0-74 @ multi ./src/main.ts

Наконец, я понизил версию пакета до версии 2.9.0, так как нахожусь в очереди на производственное развертывание. Сейчас он работает .. Очень хочу решить эту проблему. Помощь приветствуется.   —  person HelloWorld    schedule 30.10.2018

См. также:  показывать и скрывать листы Google отдельно для конкретного пользователя
Понравилась статья? Поделиться с друзьями:
IT Шеф
Комментарии: 1
  1. HelloWorld

    Используйте ngx-multi-select-dropdown:

    для более поздних версий angular:

    npm i ngx-multi-select-dropdown
    

    Это похоже на переписывание всех моих изменений. Я хочу решить эту проблему. спасибо за предложение. приветствия person HelloWorld; 30.10.2018

Добавить комментарий

;-) :| :x :twisted: :smile: :shock: :sad: :roll: :razz: :oops: :o :mrgreen: :lol: :idea: :grin: :evil: :cry: :cool: :arrow: :???: :?: :!: