Не удается установить пакет numpy в pycharm

Моя версия инструментов настройки в python — 28.8.0. И версия pip — 9.0.1. Мне не разрешено устанавливать пакеты, и я получаю это сообщение об ошибке:

Сбор numpy
Использование кэшированного numpy-1.12.1.zip
Полный вывод команды python setup.py egg_info:
Traceback (последний вызов последним): Файл «», строка 1, в файле «C: \ Users \ udari \ AppData \ Local \ Temp \ pycharm-Packaging \ numpy \ setup.py «, строка 34, в строке raise RuntimeError (» Требуется Python версии 2.7 или> = 3.4 «)
RuntimeError: Python версии 2.7 или > = 3.4 требуется.


Команда «python setup.py egg_info» завершилась неудачно с кодом ошибки 1 в C: \ Users \ udari \ AppData \ Local \ Temp \ pycharm-Packaging \ numpy \ «

Как я могу остановить это сообщение об ошибке и установить пакеты?

какая у вас версия Python?   —  person Chathu    schedule 08.01.2018

версия python — 3.3.3   —  person Chathu    schedule 08.01.2018

это просто происходит с numPy или другими пакетами   —  person Chathu    schedule 08.01.2018

Некоторые другие пакеты также не могут быть установлены   —  person Chathu    schedule 08.01.2018

ошибка: переменная среды INCLUDE пуста ‹-Также отображается это сообщение   —  person Chathu    schedule 08.01.2018

Это первая установка пакетов в среду разработки pycharm.   —  person Chathu    schedule 08.01.2018

замените интерпретаторы Python на обновленную версию Python. Посмотри на мой ответ   —  person Chathu    schedule 08.01.2018

См. также:  Добавление дополнительных модулей Python в контейнер NiFi
Понравилась статья? Поделиться с друзьями:
IT Шеф
Комментарии: 1
  1. Chathu

    Я попытался посмотреть setup.py из исходного кода вашей версии numpy на github здесь: —
    исходный код github

    setup.py используйте следующий код, вызывающий эту ошибку, поскольку используемый вами модуль numpy несовместим с установленной вами версией python.

    if sys.version_info[:2] < (2, 7) or (3, 0) <= sys.version_info[:2] < (3, 4):
        raise RuntimeError("Python version 2.7 or >= 3.4 required.")
    

    Вам следует обновить свой python или понизить numpy до 11 основной версии

    Не могли бы вы упомянуть версию SDK, которая поддерживает пакет numpy person Chathu; 08.01.2018

    @Chathu выше ›3.4 python будет работать, также, если это поможет, отметьте это как ответ person Chathu; 08.01.2018

    Спасибо, Шарма. Я удалил свой Python версии 3.3.3 и установил 3.6.3. Затем numpy pakcage успешно установлен. person Chathu; 10.01.2018

Добавить комментарий

;-) :| :x :twisted: :smile: :shock: :sad: :roll: :razz: :oops: :o :mrgreen: :lol: :idea: :grin: :evil: :cry: :cool: :arrow: :???: :?: :!: